We have noticed an outage in house P. Our systems indicate a link outage, so we expect either a physical or electrical issue.
Update 11:00: Due to an electrical fault in house P the infrastructure went out, causing a total network outage in the house.
Update 11:53: As no other outages have happened, this issue seems to be resolved.