FeM e.V. Infrastructure and System Status

All systems are operational.

Last updated 3 weeks ago
1 year ago 2025-05-15 14:49 UTC
Fixed

Fixed

1 year ago 2025-05-15 14:49 UTC

Due to maintenance work the myinfo page for network self-service is currently unavailable.

Update: The problems have been resolved