All systems are operational.
There were no more problems in the last day.
We are experiencing performance problems in our mailing infrastructure caused by the maintenances on the VM cluster.
Update: The performance problems have cascaded to more parts of our network infrastructure.
Update: Our systems have recovered. We are currently monitoring the situation.
Update: The incident has been resolved.
Incident UUID ae27df24-b7d0-4e31-8f56-fd35b0ac0bc7